The Support Department is experiencing heavier than usual call volume due to support personnel being out today.
Incident Report for Resaleworld
Resolved
This incident has been resolved.
Posted Aug 30, 2024 - 18:45 EDT
Monitoring
We will continue to call stores back as soon as possible for existing tickets.
Posted Aug 30, 2024 - 13:49 EDT
This incident affected: Support Department.