The Support Department is experiencing heavier than usual call volume.

Incident Report for Resaleworld

Resolved

This incident has been resolved.
Posted Jul 25, 2024 - 17:56 EDT

Monitoring

Opened support tickets will be called back as soon as possible.
Posted Jul 25, 2024 - 11:51 EDT
This incident affected: Support Department.