Google DNS Outage Impacting Credit Card Processing.
Incident Report for
Resaleworld
Resolved
Google DNS is back on-line. Zift reporting full restoration of service.
Posted
Jul
02
,
2025
-
21:24
EDT
Update
Zift is still experiencing service disruption from Google DNS outage.
Posted
Jul
02
,
2025
-
15:58
EDT
Identified
There is a widespread DNS outage causing service disruptions
Posted
Jul
02
,
2025
-
15:41
EDT
This incident affected: Payments (ResalePay, Zift).
×
Subscribe to Incident
Subscribe to updates for
Google DNS Outage Impacting Credit Card Processing.
via . You'll receive .